115 errors in xcode

i have the same error like in this answered question: 115 erros

but i can't solve it by disabling stripping level in unity player setting. IF that was ment!? i also tried in xcode to disable "dead code stripping" in project settings. still 115 errors. provisioning access is fully ok.

1st red error message shows: AppController.h: No such file or directory

(the paths in project settings (xcode) seem to be ok, i think so O_O)

as a newbie in xcode i really don't know what to do. the only thread i found is here, but as it is, disabling stripping level in unity doesn't solve my problem. :(

i use:

  • xcode 3.2.2
  • 3.1 iphone SDK
  • unity iphone 1.5.x !!

another information is: the unity project comes from my friend, he used to publish it successfully on his iphone. But i have ipod touch. Maybe that is causing a problem with appcontroller.h?

i really don't know to help myself anymore on that issue. i hope to find help here.

thnx in forward!!

i found out the problem: Just install unity-iphone again, then all works perfectly! problem was i used to install xcode after the unity-iphone installation. xD

"But does this apply to Unity 3.0?"

We thoroughly investigated this issue and talked to Unity and so on. It turns out the solution, the only solution, is simply completely reinstalling Unity3.0.

if you experience this problem in 3.0, the code stripping setting mentioned elsewhere is totally unrelated. The only solution is just to reinstall Unity3.0. Do not bother reinstalling XCode or anything else, just Unity3.0.

(Note, you CAN reinstall U3.0 that on your Mac, with no concerns about the tricky licensing registration. (1) put the old entire Unity folder in the bin. (2) make sure you have thrown away junk that came with pre3 versions. (3) download disk image from the website and install. (4) it will now work with your existing license with no effort. (5) your same projects, settings etc will be unchanged.)

Hope it helps someone.