2019.3 URP - Post Processing not working (Volumes)

Hello,

I’ve just updated to 2019.3 & removed the old post-processing stack. I read the documentation for the new URP post-processing with volumes & I’ve added the volume to my camera, set to global, created a profile & enabled post-pro on the camera, but none of the effects display.alt text

Am I missing something?

Thanks for any help!

I was just fiddling with it as well, wondering what was going on.
It wouldn’t work until I changed the layer of the GameObject the Volume was attached to, to Default.
Also, Unity advises to “create a dedicated GameObject for each Volume” Volumes | Universal RP | 7.1.8

Edit: Since URP 7.2, you can set the Volume Mask in the camera settings to any layer Camera component reference | Universal RP | 7.2.1

same here. it´s not working.
I have it working in an other project though, but I cannot see the difference.
is there anything else in project settings, color space, quality, … ?

Hello everyone, I wanted to point out another setting that must be set correctly in order for the Post-Processing Stack v2 to work in URP as it’s being deprecated.
Under the quality settings of the URP profile you are using, you need to switch the Feature Set from Integrated to Post-Processing v2, then Layers and Volumes will work again.

A little more specifically, also check this:
Go to your camera (I’m using the FPSController from the Standard Assets imported from the Unity Store)
Twirl Down your camera properties in the Inspector, and go down to Rendering. In Rendering, about the second item down is a checkbox for Post Processing.

When I turned PostProcessing on, it worked for me.

it didn’t work when i updated to URP so i :

  • removed the Post Process effect from the Camera (or else it won’t work)
  • used the Post Process Volume of the URP (Create → Volume → Global Volume)

@Kobald-Klaus
@PuzzledBoy

Guys, try this (YOU SHOULD MAKE A BACKUP OF YOUR PROJECT FIRST, IN CASE SOMETHING GOES WRONG):
First, right-click somewhere in your “Project” Tab, then go to: Create → Rendering → Universal Render Pipeline → Pipeline Asset (Forward Renderer).
Then go to your project settings, in the “Graphics” Tab drag-and-drop the Pipeline you’ve created (one of the two files) in the Sciptable Render Pipeline Settings field. Your materials wiil probably turn pink, but it’s okay.
Go to Edit → Render Pipeline → Universal Render Pipeline → Upgrade project materials to UniversalRP Materials.
This should do the trick but you may have to tweak the lighting if your project is in 2D.

Cheers.

For those having trouble in Unity 2020 and beyond, this worked for me:


&nbsp 1. uninstall the post processing package if you have it (URP has it built in)

&nbsp 2. in your camera, attach a script called “Volume

&nbsp 3. add the effects you want (“overrides”)

&nbsp 4. in your camera, check the box “Post Processing

&nbsp 5. also in your camera, set in “Volume Mask” to your personal layer for post processing or set to “Everything”

More info: Post-processing in the Universal Render Pipeline | Universal RP | 7.1.8

Same here,change layer to default not work for me.

Had a similar Problem in Version 2019.3.13.
Post-Processing just stopped working. I created a new Global Volume GameObject and reassigned the Global Volume Profile and now it works again. I also deleted the Main Camera and created a new one, but I guess re-assigning the profile did the trick.

I just went from 2019.2 to 2019.4 and nothing worked until I deleted existing post-process volume and recreated a new one.

anyone fixed thisss?

yeah… not at all confusing … please explain or throw some docs up… this is too much to guess at the differences… BTW the “Volume” from HDRP is working in URP… layers make no sense…

Had this problem as well, ended up uninstalling the Post Processing package and using the built-in URP features:

I solved it for me i guess.
I assume the problem was that i tried using the hdrp in the same project earlier.
The Volume Profile asset created by the Volume when i clicked new did not have the right format:

I used the Asset from the urp sample scene instead and it works fine, but newly added Overrides are still wrong.
Guess i have to move everithing to a clean Project?

URP Post-processing

  1. Install URP package via package manager.
    [Post processing via package manager does not install. It’s not necessary. URP does not support PPv2]

  2. Create Global Volume in hierarchy.
    [ex. create 3dobject > cube]
    —> Right click > volume > global volume
    —> click on new button[create volume profile]
    —> Add override > post processing > add any effect.
    [Must set in your URP rendering pipeline > Post processing > Featured Set : Integrated ]

  3. How can enable post processing.
    —-> MainCamera > Rendering > post processing Tick in check box.

[it’s not necessary to add post processing layer component to camera or VR camera.
please remove the post processing layer in camera.it’s not supported in URP]

Useful Link: https://docs.unity3d.com/Packages/c.../manual/integration-with-post-processing.html