[2020.2.01b] Unable to create new projects or load some existing "Failed to load window layout"

I had this with 2020.2.021a, so installed the latest version (01b) and still had the same issue.
EDIT: After installing 01b, I tried a new project, but didn't realise that it defaulted to the older version 021a for the new project. A new project in 01b does work, however the project I created in 021a won't load in 01b - But I managed to fix it. See my reply below.

6282467--694499--upload_2020-9-6_10-45-15.png
Choosing either option doesn't work.
Only appears on my laptop, desktop is fine. so possibly a local preferences issue.

Log (snipped)
[quote]
[MODES] Loading mode Default (0) for mode-current-id-RustTest3
[LAYOUT] About to load Library/CurrentLayout-default.dwlt, keepMainWindow=False
Failed to load window layout: System.NullReferenceException: Object reference not set to an instance of an object
at UnityEditor.ContainerWindow.GetWindowID () [0x00070] in <1ad84465318248ca98d7f06a0a057e63>:0
at UnityEditor.ContainerWindow.get_windowID () [0x00010] in <1ad84465318248ca98d7f06a0a057e63>:0
at UnityEditor.ContainerWindow.SaveGeometry () [0x00001] in <1ad84465318248ca98d7f06a0a057e63>:0
at UnityEditor.ContainerWindow.Save () [0x0000d] in <1ad84465318248ca98d7f06a0a057e63>:0
at UnityEditor.ContainerWindow.Close () [0x00001] in <1ad84465318248ca98d7f06a0a057e63>:0
at UnityEditor.WindowLayout.LoadWindowLayout (System.String path, System.Boolean newProjectLayoutWasCreated, System.Boolean setLastLoadedLayoutName, System.Boolean keepMainWindow) [0x00207] in <1ad84465318248ca98d7f06a0a057e63>:0
UnityEngine.StackTraceUtility:ExtractStackTrace ()
UnityEngine.DebugLogHandler:LogFormat (UnityEngine.LogType,UnityEngine.Object,string,object[ ])
UnityEngine.Logger:Log (UnityEngine.LogType,object)
UnityEngine.Debug:LogError (object)
UnityEditor.WindowLayout:LoadWindowLayout (string,bool,bool,bool)
UnityEditor.WindowLayout:LoadProjectLayout (bool)
UnityEditor.WindowLayout:LoadCurrentModeLayout (bool)
UnityEditor.WindowLayout:LoadDefaultWindowPreferences ()
[/quote]

I've tried clearing library/project settings/user settings folders and starting fresh to no avail.

So it appears I cannot use unity at all on my laptop with this bug present. Out of ideas on what to reset.

Fixed my current project by loading a previous project that did work, then Window->Layouts->Save Layout to file and overwriting Library/CurrentLayout-default.dwlt in my current project.

1 Like

[2020.2.02b]?

Yes I meant 01b, can't change titles after clicking post. Corrected inside my post.

As for the issue, it has just re-occurred on my desktop with an existing project (and version 01b). Occurred after unity crashed while running in the background. Replacing Library/CurrentLayout-default.dwlt fixed it again.


You can edit the title under thread tools.
6297235--696805--upload_2020-9-10_18-20-36.png

2 Likes

Oh wish I new that a long time ago … haha fixed now … though 02b is out, and probably still a bug with that … yet to have unity crash with it though, guess I have to do more work to find out :stuck_out_tongue:

Thanks @Sibz9000 this hint totally help me with the same error. This is while using Unity 2020.2.0b1.2959. In my case the error seems to be triggered by me renaming the project folder. However, did exactly what you suggested and I can confirm it works for me as well. Otherwise I would have been locked out from the project. Huge thanks for sharing.

( As a side-note, I tried all the suggestions in this other thread without any success -> https://discussions.unity.com/t/747025 )

Getting this as well, what fixes it is deleting LastLayout from \AppData\Roaming\Unity\Editor-5.x\Preferences\Layouts\default and CurrentLayout-default in the Library folder.

Happens every time I restart Unity.

1 Like

This bug appeared for me too. Totally out of the blue. I didn't rename anything or did any layout stuff.

Hi everybody,

Quick update: we have a potential fix for this issue that is currently being reviewed.

The corresponding issuetracker entry should get updated in the next couple of hours to reflect this.

https://issuetracker.unity3d.com/product/unity/issues/guid/1275270/

2 Likes

Version Unity 2020.1.8 - this bug is still there.