2D: initial sprite idle animation playing too fast upon game initiation until I input movement keys?

Hello everyone,

So odd problem I’m running into: I’m making a top down 2D adventure game and when I initialize my game, the default character facing is an animation that faces down, then after a wait of 4 or so seconds, a little glimmer passes over his helmet visor. I have all of the idle animations in a blend tree, although this down facing animation is the only one within the “Idle” blend tree that has more than one frame to it. The weird thing is is that when I first start the game, this down-facing idle animation plays WAY too fast and the helmet speed glimmers like every second, but then as soon as I move so that the animator switches from the idle blend tree to moving, then back to idle, the animation plays at the correct speed with the correct sample size I set in the animation (12 in this case). I can’t figure out why the initial animation looks like it’s playing with a sample size of 60 when the game initially starts until I move and it updates itself.

Hopefully that makes sense. I’ve double checked all the sample sizes for all the animations as well as the animation speed for the animation itself and everything looks correct for how fast the animation should be playing. In the animator controller for the player, I currently have the idle blend tree set as the default state. I tried putting in the down-idle animation separately as it’s own state in the animator controller and having that be the default state instead, but that didn’t work either. Is there a setting somewhere I’m missing that’s causing this animation speed increase upon initiation? Has anyone run into something similar to this before?

I’m having the same problem. Did you find a solution?