2D project - Sprite not visible in scene view

I know this question has been asked a lot but I can’t find any solution that works.

I started a new 2D project in Unity 2018.3.1f1 Personal version, dragged in some art, sliced it and dragged a character sprite onto the scene view. The sprite is not visible. I can see the box outline but no image. The sprite image is visible in game view though. And when I press Play.

I have searched the forums and found a variety of suggestions. None have worked.

Here is what I have tried:

  1. checked that all Layers are visible (eye icons are on)

  2. main camera z depth is -10, character sprite z depth is 0

  3. both main camera and character are on Default layer (I tried changing these including creating new layers)

  4. sorting layer for character is also Default (I tried changing this too including creating new layers)

  5. toggled 2D to 3D - I can see the sprite is aligned in x-y plane and the camera is pointing at it but still just a box, no image

  6. clicked character in Hierarchy and pressed F to zoom in - can see outline box but no image

  7. changed “Mode used to Display the Scene” dropdown (right under Scene tab) and tried almost everything (Shaded, Wireframe, etc.)

  8. changed Sprite Renderer Material property to every option - Default-Diffuse and Default-Material allow me to see Sprite image but it is washed out by a grey box over top (can’t use that in a game).

I am at a complete loss…

bumping this. I’ve even tried opening one of the tutorial projects to see if I was doing something wrong in my own, and same result: can only see sprites in game view, not in scene view (wireframes only there, and then only when selected.) Trying to get started with Unity, this is a very disappointing beginning :frowning:

@sutton_c did you ever figure this out?

This may be a long shot, but… In the hierarchy hover over your sprite gameObject. If you look at little to the left of it, an eyeball icon appears. If by sheer luck, you may have clicked on that by accident (it will be an eyeball with a slash through it). Click on the eyeball to make your sprite reappear. Just maybe… thats the issue. :slight_smile: Its also the only thing I know of that would make a sprite show up in game, but not in your scene view.