[2D] Unable to move objects in Scene View

I am unable to move objects in the 2D scene view by clicking and dragging. When I switch to 3D mode, I can move them via their 3D widgets, and I am able to change their positions via the transforms in the inspector, but I’m out of luck in 2D mode. This does not occur when I start a new project.

I ran into the same issue yesterday and I finally figured out the issue. If you collapse the Sprite Renderer component within the Inspector, you get this behavior. As soon as you expand it again, the problem goes away.

I’ve reported it as a bug.

I had this problem, but no sprite renderer in any camera.
Just close the Scene tab and open it again in Window menu. That solved problem for me.

An easy miss is the “move selected object button”. Make sure this is selected.


I experienced this issue without sprite renderers. In my case, I had capslock on for some reason, which means that when you click on something again, it triggers a “group select” box instead of moving the object you’ve selected.

Caps lock. Who knew…

Hope it helps someone: I had objects scaled negatively on some axes instead of rotating them and this cause for those objects to be un-selectable in the scene view. Fixed it by rotating instead of scaling them.

Way old thread, lol, but, now make sure the layer things are on is “pickable” or they won’t select.

try to toggle the gizmos visibility