2D Unity games - player movement stuttering/jittering?

I’m having an issue with objects looking as if they are moving smoothly. I have no issues with framerate. Vsync is on so I run a steady 60 fps at all times. The current project that I am working on has two cubes for platforms and a cube so the player can jump back and forth. This is a very simple task, yet the movement looks sloppy and jerky. Is this an issue with unity, or is there a setting that I need to change? I have messed with the timestep to check to see if that was the issue. It did cause the cube to move -slightly- smoother but it caused the physics to act a little funky as well. I could fix the physics, but all of this seems unnecessary, so I set it back to default now. I originally thought it was my smooth follow camera script, but after removing it, the jerkiness was still there.

The code for moving the cube is transform.Translate (.1f, 0, 0); and rigidbody2D.AddForce (Vector3.up * 80); for jumping.

Almost forgot, there is a directional light in the scene as well. I’m going to try deleting it real quick. -Edit: No change after deleting the directional light.

Does anyone know how to fix this? or what the issue is?

My Unity version is 4.6.0b17, but I have had issues with non beta versions as well.

Solved my problem by switching LateUpdate function to FixedUpdate in my Camera script.

I have some suggestion for you.
You have to give try to any of these options, which one work for you that I don’t know.
But generally any of these setting are working.

In rigidbody component, try to change interpolate option of your stuttering object. Generally I prefer interpolate for my games.

In Edit->Project Settings->Time, set both value same. At present Fixed Timestep value is 0.02f.
Set it for Maximum Allowed Timestep. Here changing of values are acceptable because which value work for you depend on your game.

In Edit->Project Setting->Quality, Play with vSyncCount values.
I hope, I can able to give you some useful help.