360 Video quality on Oculus Go issues

Our goal is achieve the best quality 360 video possible on Oculus Go.

However, the quality does not meet our expectations. This how our application is set up for 360 videos.

  • 1.We have set the “XRSettings.eyeTextureResolutionScale” to “2.0f” on start of the application.
  • 2.The shader of skybox is using “Skybo/Panoramic”. We have left the default values alone.
  • 3.Our RenderTexture is set at a size of “4096” * “2048”. Our RenderTexture is the same size as the video in our project folder.
  • 4.The RenderTexture located in the “CenterEyeAnchor” GameObject which can be found in the “OVRCameraRig” GameObject.
  • 5.The Video import settings of our videos include “mipmaps” disabled, “Transcode” disabled and “sRGB” enabled.
  • 6.The QualitySettings is set to “Ultra” on all platforms, all other levels have been removed. Anti Aliasing is set to “8 multi sampling”. Texture Quality is set to “full res”. V sync Count is set to “don’t sync”. Resolution Scaling fixed DPI Factor is set to “1”.
  • 7.Resolution Scaling mode is set to disabled in Player.
  • In addition to the list above, we have followed documentation in the link below.
    https://developer.oculus.com/blog/tech-note-unity-settings-for-mobile-vr/

    Please note that our settings differ slightly.
    1.Our Texture Compression in the build settings is set to “don’t override” as opposed to “ASTC”.
    2.Color Space is set to “gamma” in Player.
    3.Anisotropic Texture is set to “Forced On” in the Quality Settings.

    We have also included images from our project settings. Please let us know if there is anything else that can be done to improve the quality of the 360 videos on the Oculus Go.

    129038-screen-shot-2018-12-04-at-110609-am.png

    129039-screen-shot-2018-12-04-at-111506-am.png

    The Auto Generate Mip Maps is ticked (even though it’s greyed out)
    Maybe you need to Enable Mip Maps so you can uncheck this and then uncheck Enable Mip Maps