3d max inport not scale.

I set the units in max to meters then when I transfer them to unity its small. Do i have to set the units in unity?

If you are exporting to FBX, check Units under Advanced Options. Choose whichever setting gives a 1.0 Scale Factor. I find it best to work in inches or generic units as if they were meters (and set Unity’s scale factor to 1) or cm (and leave Unity’s scale factor to 0.01)