3ds max biped .anims as legacy - feet r slipping

Hey guys

We’ve got some animations that were originally set up as legacy - for w/e reason (programmer who set up animations doesn’t know mechanim) we can’t change from legacy to generic - because of this, im getting feet slipping

the fbx files and biped in 3ds max don’t have this feet slipping, and switching the .anim rig to generic gets rid of the feet slipping, but as above - we need to use legacy

does anyone know why legacy fbx is getting slippy feet?

There’s a setting for this. Click on your animator, select the animation state in the animation editor then on the right in the inspector there’s a checkbox called Foot IK. Checking that should be what you need