3ds max huge .fbx export

I’ve made my animation in 3ds max and I want to export to .fbx and import to unity. I’ve done this one more time with no problems. But this time, my .max file is 2,8MB and my .fbx file comes out 630MB (!!!)

I get a “Turned Edged(1)” Warning during export and it says
The FBX Plug-in has detected turned edges on Editable Poly objects. In order to preserve these edges, the plug-in has triangulated these Poly objects into Editable Mesh objects.
The following Poly objects are affected:
-Character_Mesh002

in the description. Is this the reason for my huge file?

There must be something wrong with my model, I exported it from a Blender model (to .fbx) and imported it to 3ds max (converted it to an editable poly) to do my rigging and animation…

Is there a safe way to do it? I don’t mind doing the rigging all over again if it will solve the problem for sure…

That is an enormous file! there could be a few reasons for this:

  • ‘Embed textures’ was checked in the FBX exporter dialogue and some large images (PSD’s TGA’s, or uncompressed Tiffs?)
  • Some other extra data was exported that you don’t need

To try and remedy this follow the FBX export guide:

and most crucially try the following:

  • Copy your textures into …/assets/textures and re-path materials in Max
  • Convert to editable mesh first
  • Do a poly count to sanity check the mesh > tools (hammer) > Polygon counter
  • ‘Export selected’ only, by selecting the character: File > Export > Export selected
  • Uncheck ‘embed textures’

Note - If poly count is greater than 100,000 triangles then you probably have converted a curved surface into the highest possible polygon configuration, somewhere along the line in which case you will need to optimise or go back to the original and convert to a lower polygon mesh.

After numerous tests (I tried my model with a number of different animations, I tried this specific animation with different models, I even installed 3DS Max 2014) and trying out different export settings, I figured out what is causing this issue. I don’t know WHY it is causing it, I mean it doesn’t seem logical to me, but at least I managed to keep my own sanity…

I had my character model as a single mesh and my biped skeleton, but I had kept the eyeballs as a separate mesh, which I had linked to my head bone. The reason I did this, is because I was planning to set some facial rigging afterwards (don’t know how easy it is yet, I was going to look through some tutorials later on).

For some reason whenever I choose all my objects (body mesh, bones and eyes linked the head bone) 3DS Max is working like crazy using all my RAM and I get a 600MB+ .fbx file.

The easy way to work around it is to attach the eyes to the rest of the body and export a single mesh with the skeleton. But wouldn’t I lose the possibility to rig the face then?

Hello abracadabra1980 !

The solution to your problem is to untick the “embed media” option in the FBX export options. Observe your filesize drop dramatically.