5.4.2f1 doesn't launch

So here how it acted on my system.

After splash screen showed up there were some system messages saying that it can’t copy unityeditor-collab-history-0.0.27 and other similar files to AppData\Roaming\Unity\Packages, with options to cancel, force, and retry. If you press cancel on all four of them, a blank unity startup screen shows up.

I’ve tried this:

https://forum.unity3d.com/threads/unity3d-5-3-not-working.372682/#post-2415582

And all it did is removed those copying problems from above, but launcher seems to just freeze and do nothing.

Please help me.

Ok. Here is what I’ve tried out so far:

  • copying packages to AppData\Roaming
  • installing latest beta (5.5.0b9)
  • modyfing some config-name.js file with extra code

None of these work.

But I’ve managed to figure it out, I guess my intuition helped me out. I’ve noticed node.exe process starting at the same time as Unity Editor. It stays in memory if you try to shut down unity editor, and you will try so, since it just freezes.

So, one time I’ve tried to shut down node.js process before unity. And it worked. I was actually able to launch Unity. What a strange discovery I’ve made today.

Can somebody help how to avoid shutting down node.exe process every time I start Unity?