5K textures / game view

Since we can now downscale the game view in 5.4, I'd like to set my game view in the editor to a 5K resolution (5120x2880) for various reasons, like creating image sequences for film. When I do that by creating a fixed resolution preset for the game view I get following error message:

GameView size clamped to maximum texture size for this system (4096)
UnityEditor.HostView:OnGUI()

Resolutions until 4096 work fine.
Could this be a hardware problem of my computer? My ATI Radeon 6750M theoretically should support up to 16384x16384 textures. I'm on OSX 10.11.5 with 5.4b22.

To see if it's a general problem with textures of this size, I also tried just importing a 5120x2880 texture with max texture size to 8192. But an imported image with white background and 1px black lines are rendered gray and downsampled in unity. At the same time, Texture2D.width of the (not packed) sprite texture says it's 5120 wide.

Here you see the difference between the picture in photoshop (only black and white) and the same texture in unity (point filtering, without mipmaps, max size 8192).

Any ideas what could cause this?

2688551--190147--Screen Shot 2016-06-21 at 15.59.25.png2688551--190146--Screen Shot 2016-06-21 at 15.59.00.png

Hey any_user,

The issue with the imported texture is likely a matter of import settings. My guess would be that it's being forced to power-of-two dimensions and resampled, but I can't be sure without seeing the full settings.

With respect to the Game View, there could be a few different issues, and we're still working out how to avoid people crashing their machines with giant resolutions. Can I get you to file a bug report and post the number here? This will provide me with system information and a way of tracking the issue.

Thanks,
Daniel

Thanks for the reply, it was indeed resampling the texture to power of two dimensions, a 8192x8192 texture works fine. I guess I work too often with the sprite packer to forget about that constraint.

When I tried to set the 5K resolution in a new project it worked. The issues was that OpenGL ES 2 emulation was activated in the other one. A better error message would be helpful in this case.

With the working 5K game view, I noticed another odd issue. I tried to take screenshots (Application.CaptureScreenshot, without supersize) in the editor, and had two problems:

— I always get this error message in a new project each time I capture a screenshot (didn't get it in my old project):

GfxFramebufferGLES: An active RenderTargetSetup has dangling pointers.

— Even with that error message, taking screenshots work, but a screenshot of the 5120x2880 viewport is only 4230 x 2379 pixels, which I don't completely understand. Screenshots made with smaller viewports have the right size, (eg. with a 3840x2160 viewport, a screenshot of the same size is created). This also happens in a project that doesn't show the "dangling pointers" error message, it seems to be unrelated.

No graphics emulation is enabled and editor is set to Standalone OSX for these tests.

And here are the bug report numbers:
808623 unclear error message
808617 GfxFramebufferGLES error
808627 screenshot resolutions

Looks like you've found a whole nest of issues! Thanks for the bug reports.