a failure occurred while executing com.android.build.gradle.internal.tasks.workers$actionfacade

I have seen a lot of sources about this problem but nothing really worked, I want to publish my game to play store but when the abb built and When I Upload it to play store It says that the target must be 30 but my highest API level downloaded is 29 so I downloaded API level 30 but I can’t build the game now and it says “a failure occurred while executing com.android.build.gradle.internal.tasks.workers$actionfacade” Someone said to edit the gradle file and change the level to 30 but I have no idea how to to this, If anybody have solution please answer…


Try to change your keystore, I mean retype your key and try building again. I had this kind of error, but if carefully read the build log, it says for me,
CommandInvokationFailure: Gradle build failed.

went wrong:
Execution failed for task ‘:launcher:packageRelease’.

A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
com.android.ide.common.signing.KeytoolException: Failed to read key {name} from store “C:\Users.…{name}.keystore”: Cannot recover key".

Also, changing the Android SDK directives should not affect the application build, since Unity by default installs modules that are recommended for a given version of the editor. Yes, some versions of “Unity” had build problems, with “Grade” or “build-tools” versions, but that was in the past, you can find forms with the same problem as yours. GL)

I have the same problem though this Keystore thing is disabled.

ok,I’ve had the same problem in unity2021, you can set your Publishing Settings to add new key. The source comes from this connection : https://blog.csdn.net/sunrui13075553500/article/details/125166036