Access Denied

I'm facing a problem with Unity Forum. Whenever I try to open it, it says: Access Denied

Keep in mind I'm only facing this problem recently (less than 2 months), however it started to get more intense/often!

Is it a problem with "Cookies" being corrupted or something? or even worse, Is The Forum Being ddos Attacked?! Keep in mind I've been using this site for more than 2 years now, Never faced this problem before until recently, and it's getting really annoying, because if you face it you have no other choice but to clear all browser settings, history and cache etc to get it back working! And even then, you might still face it as I did!

I'm making a poll right now. Please, I want from everyone to participate in this so we can get this issue raised and looked up by Unity Technologies. Thank you!

https://discussions.unity.com/t/860794

[quote]
https://discussions.unity.com/t/860794
[/quote]
it seems that the problem is widespread! Please, vote so we can raise it up a bit!

And quick question: Since when have you been facing this issue? Let's make a survey for Unity to know!

[quote]
it seems that the problem is widespread! Please, vote so we can raise it up a bit!

And quick question: Since when have you been facing this issue? Let's make a survey for Unity to know!
[/quote]
I'm pretty sure they already know about that.

If you don't mind, how do you connect to the internet when this happens? I use my phone as a wifi network, I don't have a "fixed" connexion at home.