Activation problems / License error


I’ve been struggling all day with activating / installing Unity 2018.3.2f1 for the first time.
I’m using Windows 10 1809


When first installing Unity, I logged into my Unity account and tried to activate a personal license.
After filling out the quick survey and submitting it, nothing happened and the form was unresponsive.
Then I restarted Unity and got a License Error and got the option of re-activating it.
When doing that, I briefly get a window saying “Activating - Almost there!” before it throws me back to the “License Management” window which is now unresponsive. Clicking “next” here now triggers the green loading bar at the top to move, but nothing happens.

What I’ve tried:

  • Reinstalling Unity after deleting registry entries, ProgramData folder and %user%\AppData{Local, LocalLow, Roaming} folders
  • Offline / manual activation (When loading the license file it says “loaded successfully” but nothing happens and the only option I have is to press cancel)
  • Trying an earlier version of unity
  • Updating windows
  • Different unity account
  • Changing my timezone as per instructions from a different post I found
  • Temporarily disabling my firewall

I’m completely out of ideas and really hope someone have some suggestions.


I’m having almost the exact same problem! I had this early last year in May 2018, but could not find a solution then either…

When I came back to school after the weekend where the computer in question is located, Unity started up without any License Error and I got straight to the project creation screen.
Dont know if this had anything to do with Unity activation servers, or something to do with the schools network, but I didn’t change anything over the weekend.
Sorry that this won’t help you @spatialar. I got this answer from the Unity support team when creating a ticket that might help you:

Hi Marius. Thanks for getting in touch, sorry to hear you are having this issues with your license. From the error message you are getting, this is an indication that there may be a connectivity issue between your machine and our license servers, sometimes having a HOSTS files, VPN or Proxy, tricks the system to think that it’s not a valid IP address, to fix it, please do this: If you have a firewall or proxy in place. These can block the connection to our servers. Please try allowing these ports in your settings: 80 and 443. If you have an anti-virus software. Please try disabling this and seeing if the sign in will work. You can also try whitelisting these URLs: & Please try the suggestions in the points above and let me know how you get on.

Good luck!

I am having the exact same symptoms however, Trying both posted potential solutions led to no resolution. I removed all virtual adapters from my computer, uninstalled my AV all together as it also was creating a virtual adapter that the LS kept trying to use. Now that I have it trying to use the right adapted with no firewalls or antivirus protection active, I am still getting the same result. I have attempted reinstalling Unity, removing all registry values for unity between reinstalls I am at a loss.