Adcolony for iOS not working in xCode 5

As the title suggests, not working in xCode 5.1. Tried following the instructions on the Adcolony page. Tried building with Pro and letting the postproccessing work with it. Nothing.

The main issue that always comes up first is “‘AdColony/AdColony.h’ file not found”. I’ve tried several things, but only directly linking it to the exact path gets rid of the error. That’s when other errors come up (one of them being that the architecture is not compatible with i386 or armv7, leading to unrecognized symbols). I have been going at this for a couple days now and no luck…

Anyone played around with this in xCode or know what’s going on?


Sorry to hear that you are experiencing trouble with your integration. May I ask, what version of Unity you are using? Did this occur while building the Sample App that we ship with the plugin? I’ve just run some tests with the latest version of Unity 4.3 and everything is working as expected. Occasionally users have issues using the automated Xcode project setup (the PostprocessBuild scripts). In these cases we recommend following the Manual Xcode Project Setup outlined in our documentation(link below.) Its not clear from your description whether or not you tried this already. Can you confirm?

We will do our best to help resolve your issue, any other information you can provide will be very helpful.

I just noted that in my case, the generated Xcode project is containing a link to AdColony.framework.meta instead of AdColony.framework (in the Libraries folder). @AdColony_Support: Can you check how this could happen?

So I know this question is quite old, however I ran into the same issue just recently as I was Integrating AdColony for UE4.

I realise this is the Unity forums, but i figured I’d post here for posterity as the issue could possibly be the same.

My issue ended up being that all the symbolic links within the AdColony.framework broke as I derped and unzipped the framework on a windows machine.

So if anyone else is seeing this, make sure they aren’t broken on your machine, and your version control is handling Sym-Links correctly.

Hope this helps. :slight_smile: