(Add Log text)Crashed when running Command Line in Pure Command line interface of Ubuntu 15.04

I’m facing an problem:
Today I tried to run the Unity Editor in Command Line In Ubuntu:

/opt/Unity/Editor/Unity/ -nographics -batchmode -quit

It worked in Graphics interface but Crushed in Pure Command line interface and throw that:

Aborted(core dumped)

Can I get more help to fix that?

Thanks for sight.2307874--155461--crush.jpg

LogFile:

2307874--155464--Logba.txt (418 Bytes)
2307874--155465--Logbano.txt (1.64 KB)
2307874--155466--Logno.txt (6.47 KB)

Any Feedback Please?

I think you are running into the same issue I was having, while setting up automated builds (via Jenkins). I believe the editor tries to display a splash screen even when -nographics is enabled, and handles the lack of X server very poorly.

I can partially get around it using xfvb-run (sudo apt-get install xfvb), which runs a headless virtual X server.

However, Unity still crashes unless the Jenkins user is logged into the actual X server. I admittedly don't know much about the inter workings of X, but my suspicion is there's environmental variables that aren't being properly followed.

In my case, setting the Jenkins user to autologin is an acceptable solution. This might not be a secure solution for some setups.

If you are running 100% headless with no Gnome/KDE/etc desktop environment at all, it's possible that you just need to wrap Unity in xfvb-run.