Add shadow to player

As shown in the picture, all other objects in the scene have shadows but my main character has none. I have forward rendering with a directional light and soft shadows enabled from project settings. I also have another animated object on the scene without shadows, once again. Maybe this has to do with animations?
Any help welcome.
alt text

Ok solved it by changing the shader of each child to Diffuse