AddTorque doesn't rotate?

Their are no console errors but this is the line i'm trying to make and it wont rotate, also just so you know it's part of my airplane, which has a 1000 mass rigidbody, and its already got a 350000 force acting on it to move it fast so could this be effecting it?

if(Input.GetKey("d") && (groundtrigger.triggered==0))
rigidbody.AddRelativeTorque(Airplane.transform.right * -banking);

i just tried making a test and i put a script like this on a cube. and it worked... then i copied and pasted it and made so it would be focused the the airplane and it doesnt work, but if im on the ground and i the torque is like 20000000 it would jump into the air, why wouldn't it rotate like it is supposed to, i even erased the trigger part? so i dont have to worry about that.

Does the rigid body have infinite air drag or is there a constraint on the rigidbody that locks rotation ? Also what is the nomenclature ? The script is applying a relative torque in the world right direction of an Airplane reference ?

try doing something basic first:: Airplane.rigidbody.addRelativeTorque( Vector3.right, 100000);

Sidenote: I prefer the style where the rigid body has low mass, and I account for the forces in my controller rather than have it on the rigidbody.

Check to make sure you have a RigidBody and that its IsKinematic box is not checked.

Also be sure you are applying the torque to the object with the RigidBody and not a child.

(For future readers who happen on this thread via search like myself)

I had a similar issue and I solved it by adding Torque on the frame after adding force:

Rigidbody.AddForce(targetPlayer * LaunchSpeed, ForceMode.VelocityChange);
StartCoroutine(AddTorqueCo(TransformRef.right * this.SpinSpeed));

private IEnumerator AddTorqueCo(Vector3 torque) {
    yield return null;
    Rigidbody.AddTorque(torque, ForceMode.Force);