AdMob Plugin doesnt work in any case

I think I’ve tried everything to make the Official AdMob Plugin work on my test device (Nexus 5 Android M). The part with ad request stops further code exectution, ex. when I put ad request in Start() in Player, the Player won’t work (Update() isn’t even called , furthermore the code behind ad request in Start() isn’t executed). What I’ve done by now: reimport all, reimport plugins lots of times (AdMob and Play Games Services), reinstall Unity (I’ve tried both 32 and 64 bit versions), downgrade Unity, start new projects. I tried lots of code examples with dozens of configurations. I reinstalled Operating System (Windows 10 64bit)(but I was planning this for weeks to clean partitions). I installed almost every package via SDK Manager, I installed (both 32 and 64 version) JDK. I tried to use different AdMob account (on another Google Account). And obviously I tried tons of solutions from Unity Answers.
So is there anyone who knows what else can I do? I’ve already lost about 40 hours and nothing changed since I’ve started… I think I should switch to Unity Ads, but I really don’t want to do it.

I’m fighting with the same problem. So frustrating.
I logcatted my device and it just says “ERROR 403, can’t load ads” when it tries to request one.