Advice/question

So,

having had a few issues, I built my current work in progress for webgl and got in my chrome console

You can reduce startup time if you configure your web server to add "Content-Encoding: gzip" response header when serving "Build/Build.data.unityweb" file.
Build.loader.js:1 You can reduce startup time if you configure your web server to add "Content-Encoding: gzip" response header when serving "Build/Build.framework.js.unityweb" file.
Build.loader.js:1 You can reduce startup time if you configure your web server to add "Content-Encoding: gzip" response header when serving "Build/Build.wasm.unityweb" file.

so I added

 <FilesMatch "[^.]+\.unityweb$">
  Header set Content-Encoding "gzip"
</FilesMatch>

to my apache config and... 2 of them went away but not

You can reduce startup time if you configure your web server to add "Content-Encoding: gzip" response header when serving "Build/Build.data.unityweb" file.

Can anyone tell me why?

Try using Chrome DevTools Network tab to inspect the "Response Headers" of the web request (see https://developer.chrome.com/docs/devtools/network/#details ) to see if the Content-Encoding: gzip option actually stuck with the web server.

If using Firefox or Safari, they will both have similar developer panels as well that allow viewing Response Headers of the Build.data.unityweb file.