After Reimporting, all of my prefabs are marked as 'missing' and every script component is missing as well. PLEASE HELP

I was having some issues with some AssetPacks not being assembled correctly and I was getting 999+ errors, a bunch of different things. such as;

  • Assertion failed on expression: ‘errors == MDB_SUCCESS || errors == MDB_NOTFOUND’
  • LMDB_Transaction::Run - LMDB error = 22
  • Assertion failed on expression: 'errors == MDB_SUCCESS || errors == MDB_NOTFOUND’UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)
  • LMDB Transaction::Run - LMDB error = -30781

After looking around for a solution, I read that it was a error within Unity and I would need to reimport all my assets. Then I was able to open my project in Safe Mode. After that, I was getting 250ish errors from 3 of my AssetStore packages. Including;

  1. Febucci’s Text Animator
  2. UI Particle Image
  3. Advanced Scene Manager

All of these errors looked something like this,

  • Assets\Plugins\Febucci\Text Animator\Scripts\Runtime\Components\Typewriter\Built-in\TypewriterByCharacter.cs(26,26): error CS0246: the type or namespace name ‘Attributes’ could not be found (are you missing a using directive or an assembly reference?)

After looking around I determined that it was an issue with the assembly.
So I tried exiting Safe Mode to see what would happen, not much changed from what I could tell.

After some searching around in Febucci’s support discord I found someone who had a similar issue, and Febucci had given that person this advice,

“you need to reference Text Animator assemblies. If you’re getting weird issues 'cos Unity, I suggest closing the project, going before the “Assets” folder and deleting all .csproj and .sln files, and then opening Unity again. This will force the Editor to generate assemblies”

So I tried that, but I made copies of those files before deleting them (just in case)
Then when I reopened the project, I was no longer getting the errors I was getting before but instead I was getting 35ish new errors.
Basically all these Errors were labeled ‘Prefab instance problem’.
And all of prefabs in the Hierarchy looked like this
image_2024-01-14_213800336

After looking around some more, I was able to find out that it was because the guids of the prefabs were not what they used to be. (my guess is because of the reimport)
By going into the prefab’s ‘.meta’ files I was able to change the guid to match what the editor was looking for and that fixed what they looked like in the hierarchy. However, I havent changed all the guids yet because even with the few I have fixed, this is what they look like in the Inspector.

(I’m only allowed to have one image in my post so here is a link to images for this part)

While I could go through each individual prefab and put in all the missing component properties, that would take me forever. And this whole thing has been very frustrating. I do not even know what I did to cause the initial errors as everything was functioning perfectly fine when I finished working on it last night. It all of a sudden got messed up when I tried to open it earlier today.

Basically, what I’m asking is if there is any way to fix this all without individually doing every prefab and all it’s components and all of their properties.

Any help would be significantly appreciated thanks in advanced.

(Also sorry if this is too much information, I wanted to include everything that happened so I didn’t leave out a detail that could help fix it.)

The Febbuci assets could have been made in an older Unity version and might be incompatible with yours. Have you checked the version they are made for?

In order to fix the issue, hopefully you are using VC and can revert, or you will need to delete the Febbuci stuff you imported into your project. Save in VC after getting back to the base point before you imported Febbuci assets and try again.

Also you don’t need to save old .csproj and .sln files, these are autogenerated if they are not there, and you should delete them so that the project generates new ones compatible with your computer.