Afterimages occur in scenes created in VR


I am experiencing a kind of afterimage in a scene I created in Unity.

It seems to occur only in the scene I created, since it works fine in Oculus Rift tutorials and other games in VR.

I get a gaggle or something like an afterimage around the object.

It appears normal when I look at the editor preview on my PC, and only occurs on the images I view through VR.

The afterimages get larger in the direction I move my view.

Does anyone know what could be causing this?

【What I have tried】
I created a simple scene with one Cube and one Plane and Global Volume disabled.

The lights are also pre-baked, and without VR on, the scene maintains about 250 FPS.
(With VR attached it is 45 FPS).

I thought it might be due to the editor being too heavy, so I tried building and running it as an exe, but that didn’t improve it.

I have been using this person’s video to help me proceed.

Thank you in advance :slight_smile:

Windows 10
Unity 2021.3.4f1 (URP)
XR Interaction toolkit 2.5.2
Oculus Rift