AI window gone?

,

I'm seeing the navmesh visualised in the scene, and i want to turn that off. Usually i would go to Window > AI, but now this is no longer there. I dont have the AI navigation package installed, using Unity 2022.2 beta.

8558918--1144889--upload_2022-11-3_8-26-44.jpg

Why was this removed, how do i turn off this visualisation now?

Thank you for raising this issue. The only way to control the NavMesh visualization in 2022.2+ is made available by installing the AI Navigation package. Only then you can disable "Show NavMesh" and "Show HeightMesh" from the overlay in the Scene view. After that you can remove the package again and your preference will persist for future sessions. If this affects your workflow please report a bug.
We'll consider adding an approach that does not involve the AI Navigation package.

2 Likes

[quote=“adriant”, post:2, topic: 899038]
Thank you for raising this issue. The only way to control the NavMesh visualization in 2022.2+ is made available by installing the AI Navigation package. Only then you can disable “Show NavMesh” and “Show HeightMesh” from the overlay in the Scene view. After that you can remove the package again and your preference will persist for future sessions. If this affects your workflow please report a bug.
We’ll consider adding an approach that does not involve the AI Navigation package.
[/quote]
Is there any workaround? My team is not using the package and I just need to hide the gizmo. What does the package toggle, maybe I can just do it myself in custom inspector?