All Unity Engine games' controls not working

So I recently noticed that a lot of my purchased steam games’ controls are not working properly, for instance the player was walking forward and to the left and the camera was pointing upwards and spinning. I wrote a list of the games that were doing this and what they were doing, and I looked up the games’ engine individually and found that they were all using Unity’s engine. I’m not sure what’s causing the problem, I have updated all my drivers, my OS, ran the games in safe mode and so forth, and so I think it’s definitely caused by the engine and not my computer. So I know this isn’t a question about the Unity Editor, but I’m not sure where else I should ask the question. Here’s a table of the games and the defect that they’re causing:

Also it seemed in Ori and the blind forest, the menu options were showing the ‘X,A,B,Y, RB, LB, RT, LT’ Controller controls for each option, so maybe my laptop thinks that there’s a controller plugged in, when there’s not. I haven’t got any external mouse, keyboard or controller plugged in so I don’t know what’s causing it.

Here are some of my specs:

OS Name Microsoft Windows 10 Home
Version 10.0.10586 Build 10586

OS Manufacturer Microsoft Corporation

System Name DESKTOP-8B5IRL4
System Manufacturer HP
System Model HP Notebook
System Type x64-based PC

Processor Intel(R) Core™ i7-4510U CPU @ 2.00GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)

Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.92 GB
Available Physical Memory 3.98 GB
Total Virtual Memory 9.17 GB
Available Virtual Memory 4.89 GB

Also, I’m pretty sure it’s not a compatibility issue with windows 10, as most of the games were working with windows 10 before. I also recently installed the windows 10 update, and it didn’t fix anything. I’ve also tried running an ‘sfc /scannow’ command in CMD prompt, restarting my system in safe mode with command prompt and running the game directly from the command prompt, disabling my anti-virus and updating all my keyboard, controller, and mouse related drivers and none of those things worked.

It would be great if you could help me out here, as it makes most games impossible to play, thanks.

Okay so, for anyone who’s curious, I decided to go into my device manager, disable all of my controller drivers and restart my computer, and the problem went away, so I re-enabled them one by one and found out that is was being caused by a driver called “HID-Compliant game controller.”

I don’t know why this was causing a problem but it worked anyway.

It works thank you!,It work hank you!

It worked for a while, then I wanted to enable the HID-Compliant game controller but it disappeared and I don’t know how to download that driver anymore and the problem continues