Alpha 11: Can't rotate scene view

I just installed 2022.2.11 (Windows 10) and I can't seem to rotate the scene view. Panning works fine. Pressing the axis view buttons work fine. Anyone else experiencing this?

Yes same for me, pretty sure unity QA was on holiday when this was released

Amazing, just change the scene view shortcuts in the process, why the hell not

Oribiting
Of course, orbit has never been Alt+Mouse 2. It's Alt+Mouse 0.

Panning
I pan with both Alt+Mouse 2, and just Mouse 2, swapping between the two based on previous contexts. Now I cannot have two shortcuts assigned, so even if these were 'correct', I can't use it.

I have no idea what "Temporary Pan Tool for 2D Mode" is but it doesn't seem to be working. Why is there a 2 on "Temporary Pan Tool 2"?

Inconsistencies
I'm unsure this is my mouse causing problems (mine double-clicks occasionally), but it's worked fine previously:
With the new setup going from any other scene view mode into oribit (with orbit changed to alt+mouse 0, like it's meant to be) it fails inconsistently, not going into orbit mode properly.

Here's a gist that adds an extra pan shortcut.

2 Likes

@LeonhardP Can unity default to the old behaviour please?

Millions of unity users are not going to be happy relearn how to rotate the scene view.
Its good that you can customise the mouse shortcuts but default should not be changed, Thanks!

7 Likes

Did unity hire the person who decided you cannot Save As in Photoshop anymore, but instead you need to save a copy? Are these people making these decisions even working with unity?

2 Likes

“F / Frame Selected” also appears to be non-functional … swapped to another key for no good reason?

Of course, orbit has never been [B]Alt+Mouse 2[/B]. It's [B]Alt+Mouse 0[/B].

"F / Frame Selected" also appears to be non-functional ... swapped to another key for no good reason?

:hushed:
Screwing up classic Maya like shortcuts..

I suppose if they are wanting to drive people away to other engine editors messing with the absolute classic input navigation basics is one way to achieve it. They've already got me looking around because this broken URP/HDRP insanity.

1 Like

Frame selected is fine here. It's still set to the default binding of F.

Hi everybody,

The change of the default orbiting shortcut was not by design, and a fix is being worked on. Until then, please re-bind it manually to work around this.

6 Likes

Thanks for bringing us this good news!

1 Like

Well I'm glad it's not by design.

1 Like

Argh. The issue persists in Alpha 12 :(

The work-around is to change the settings for Shortcuts -> Scene View -> "Temporary Orbit Tool" and "Temporary Pan Tool 2".

What a mess.

1 Like

guys relax its not that big of a deal. i personally cant wait when wasd is accidentally replaced with arrow keys movement in scene view.
(on a serious note i guess this is a good opportunity to find better and more optimal shortcuts)

hmm

Well 3 weeks later and seems this default functionality wasn’t a big enough deal to fix…

Stuff like this bugs me.

Should now be fixed in Alpha 13.

Rotating works in Alpha 13

But.... I cannot pan anymore for some reason

You will need to fix shortcut conflicts in the settings, resetting the scene view shortcuts that are modified (Edit/Shortcuts/Scene View) should fix it.

Yes the panning is fixed now,

Sadly its still not like it was, I want to have the zooming to work when I have ALT pressed and also when I don’t have alt pressed.
I cannot bind two shortcut keys to one function.