"Always animate" doesn't work using Application.loadlevel.How to fix it?

Hie,

I’m a beginner and I try to make a “chrismas calendar” application using unity.It’s a very simple application.
To do that I made 31 scenes with in each one :

-one animate number (just a rotation on Y axe)
-one animate background (a plane with y offset animation)
-one frame import from maya as FBX export (with animation on it)

So in my scene I loop all the animation and just put them on “Always animate”.
It works fine.

I put in each scene an empty gameobject with a script on it:

public class QuelJour : MonoBehaviour {

void Start ()
{
   

	if ( DateTime.Today.Day == 1) 
	{
		Application.LoadLevel(0);
	}
	if ( DateTime.Today.Day == 2) 
	{
		Application.LoadLevel(1);
	}

etc…until 31

So it took the day of the device and load the scene well.

My problem is , when the scene is load like this, all animation are freeze and nothing moove.
What’s the the problem?

I search on the net but I don’t find the answer…

(I alreay tried " Application.LoadLevelAsync, Application.LoadLevelAdditive, Application.LoadLevelAdditiveAsync." but nothing work. The animation start with the additiveASync but create many instance of the gameobject).

Many Thank’s by advice

You didnt say you made the animation in unity.

In that case disable any animation import in the importer. Use the legacy animation component.

Make sure you add your animation clip to it as the first clip.

Check the box that says “Play Automatically”

thank’s for the answers.

I just find the solution.

The problem was:

I put the script which check and load the scene in all the unity scenes. That was the mistake!
I just put it in one scene and delete it from other.
Now all work fine :slight_smile: (apologyse for my english…).