Analytics cache not flushing and growing larger each run

The Analytics cache in my project is not flushing.
"Flushed up to token index 1162, cache file is 31568B" Cache keeps growing after each run, even if editor is closed and restarted.
Also tried AnalyticsService.Instance.Flush to no avail either.
I did have a bug in which I tried to send something that had a null-value... suspect that was when it started.

Any ideas??

I encountered this during the beta and in my scenario, it was due to embedded JSON causing serialisation issues...

https://discussions.unity.com/t/872816/13

You should be able to use Charles Proxy to determine the exact location of the malformed JSON (if that's what it is)

Having a single malformed event stop Analytics completely in its tracks is far from ideal.

[quote=“rayD8”, post:1, topic: 894431]
Any ideas??
[/quote]
Yes, a single malformed event will stop analytics completely.

We are very keen to see a broken payload if it’s been caught out in the wild. If it’s possible to remove personally identifiable data/etc then feel free to post here, otherwise DM me and I’ll share it with the team of engineers.

We have actually fixed this issue internally, but the fix is currently blocked due to ongoing issue shipping version 4.2.0.
Be sure to keep an eye out for an update sometime soon. No ETA currently.