Android API level with unity 4.1

Hi, I have unity 4.1 and I want to build my android app with API level for android 4.4 , but in the build settings I see up to 4.2 . I wanted to ask if this is related to my android sdk or unity is also limiting android build on lower versions.
Thanks very much

Sorry I can miss some 4.1 version specifics because I started working with 4.3.

Well, you probably cannot set the minimum SDK level to 19 (Kitkat), but is this what you are looking for? TargetSDK should be set to the latest platform available in your Android SDK. Just check the resulting manifest and see whether it has the expected values. If not - then it can probably be overridden by putting your manifest into Plugins/Android/AndroidManifest.xml.

For difference in minSDK and targetSDK, please consult eclipse - Android Min SDK Version vs. Target SDK Version - Stack Overflow or Google documentation.