Android APK Build Failing "Execution failed for task ':launcher:checkReleaseDuplicateClasses'."

I’m trying to make an APK build but I’m getting the following errors:

**FAILURE: Build failed with an exception.

What went wrong:

Execution failed for task ‘:launcher:checkReleaseDuplicateClasses’.

1 exception was raised by workers:

java.lang.RuntimeException: Duplicate class found in modules classes.jar (:androidx.core.core-1.0.0:) and classes.jar (**

…along with 330 other similar errors which I believe to be related. (I will leave the full error message in a comment below).

I’m not very knowledgeable about these sorts of issues so a dumbed-down solution would be appreciated.

I’m having the same issue, I change the Gradle Properties to use Jettifier, change the AndroidManifest.xml but still nothing, would appreciate if someone can help T_T


I fixed it by going to Assets > Play Services Resolver > Android Resolver > Delete Resolved Libraries.

Same for me.
I’m using Firebase and Facebook sdk. Everything works perfect on ios but i cant build on android, the only way for it to build is if i completely delete the plugins folder, but then firebase won’t start of course.

Tried using every version of 2019.3 and 2019.4 on mac, same 498 duplicate classes errors everytime.

Also tried:

  • Deleting resolved libraries
  • Resolve / Force Resolve
  • Update version handler
  • disable patch mainTemplate.gradle
  • deleting the sdk 14 or something on firebase AndroidManifest
  • updating and downgrading all plugins (now they are all in their latest version)
  • deleting library
  • deleting the folder, creating a new one and transfering packages and assets folders into it
  • restarting computer
  • everything in every thread ever


Same here. Any resolution? Thanks.

I’ve fixed that issue by deleting the playcore.arr file from the Assets/GooglePlayPlugins/ folder

I use Mediation for ad. And my solution was just remove the “Advertisement” package on Package Manager from “In Project” tab.,I had the same duplicate classes error but not in the same files, for me it worked deleting one of those files: