Android: App Chrashes after starting

Hi,

Im working on an AR App with the Vuforia SDK an Unity.

Evreytime i try build an app it closes right after the screen is getting dark and a message appears. Which says something like "sadly your app is closed" (Translation from German Android version).
Even when i try to Build one of the sample app´s "Frame Markers" for example
The device is a Samsung Galaxy Nexus

Android version 4.0.4
Vuforia version: 1.5.9

Log file is in the Attachment

Thanks, Ihno

915516--34328--$log.txt (12.3 KB)

Are you using old/outdated Eclipse Project files?

Some old tutorials suggest to copy some *.java files from C:\Program Files (x86)\Unity\Editor\Data\PlaybackEngines\androidplayer\src\com\unity3d\player in your eclipse project, which is not the best way, especially when the original files get updated.

Instead one should reference C:\Program Files (x86)\Unity\Editor\Data\PlaybackEngines\androidplayer\bin\classes.jar into the eclipse project. Also remember to always use the most recent AndroidManifest.xml which can be found at C:\Program Files (x86)\Unity\Editor\Data\PlaybackEngines\androidplayer\AndroidManifest.xml

It's important to use the most recent classes.jar/AndroidManifest.xml in order to make sure it runs well on devices running new OS versions (especially Android 4.0)

I was just having a similar problem with my AR project, but solved it while writing my post here :) We're building a demo using Unity and the Metaio SDK for Augmented Reality, and it was crashing after the Unity splash screen, but before the Metaio splash screen. No error message, just a black screen, crash and close. However, this only happened when trying to access the app from the shortcut on the device. Build and run from Unity editor worked with no problems.

Earlier in our project, we started a fresh Unity project to test our .unitypackage import stability. This resulted in two different projects on my system using the same bundle identifier, which then created two Applications on my device that were linked to the same source... Needless to say, not a good thing. After erasing all Application data from the device relating to our project, I rebuilt and it once again would open from the Application shortcut.

Unfortunately, this doesn't really sound like your problem - you said you were having problems building in the first place. Maybe the above results can help out someone else with Android AR crash problems. I haven't used Vuforia, but if what you are describing happened with Metaio I would suspect that the Application Signature and the Bundle Identifier you're using don't match up. If Vuforia has a similar process that requires you to link an app signature, and you haven't done that, then it would crash when trying to use the AR portion of your build.

My project system:
Samsung Galaxy S2
Android 2.3.6
Unity 3.5.1
Metaio SDK 3.1

Hello,

I'm new to this so one question that I saw it repeats a lot, but it seems I simply cannot find the answer.
I installed everything properly (I'm and android developer, so i had a lot of stuff, but just in case i followed the tutorial completely, so i have the same structure) like said here:
https://ar.qualcomm.at/qdevnet/sdk/android
And then i went to: Step 2: Compiling a Simple Project.
Everything build fine, apk is created, but when i run it on my device, crash...
ERROR/AndroidRuntime(14445): java.lang.NoSuchMethodError: com.unity3d.player.UnityPlayer.windowFocusChanged

this one seems to be a popular one, but with no solution that i could find.
I tried to get this project from StagingArea also and compile it in Eclipse, and the same error occurs.
When I declare this same project an library (http://unity3d.com/support/documentation/Manual/Android-Integrating%20Unity%20With%20Eclipse.html) it compiles (however there are some manifest errors about the screenSize, but i fix it by removin' it :) ).
When I run the project like this, it starts, it shows the splash screen, and than the black screen and nothing happens.
Camera is not activated, so i cannot scan the marker.

Can some one please help me with this to move on? - I'm stuck with this for about two days now, and starting to get frustrated so much I'm thinking about abandoning this AR (but it looks so promising).

I'm running HTC Desire with CyanogenMod 7 (Android 2.3.7), on Windows 7 x64.
Unity 3.4.0.0f5 with vuforia vuforia-sdk-android-1-5-9

dude... i had the same problem.. just update to unity 3.5 ...

I have just the same problem. Between the unity loading screen and the metaio loading screen the app crashes.
Because I want use the already existing android classes I have to expand the unity project in eclipse. I already tested the import workflow but if I include the Metaio sdk in my Unity project I get results as described. Even after erasing and reinstalling the app whether or not I start by clicking the shortcut or launching from eclipse,... it's not working. Thanks for your help.

Try to change shadow values in Quality Settings. Hope it helps....