Android App icon does not show up

the icons are in the final apk in res/mipmap folders all named app_icon.
i checked the manifest and it has the correct reference.
i tried updating sdk tools.
i tried having default icon filled in.
i tried having different icons.
i built a new project with just the icon and it doesn’t work.
plz help.

Solved it myself after trying a lot of things, hopefully this helps someone in the future (upvote the original post if it does so others will see it)!

-First of check the API level of your Android build tools by opening Android Studio (yes you need to have this installed it’s so much easier to update tools later on imo). File>Settngs>Appearance and Behavior>System Settings>Android SDK. You will see some that are checkmarked, which means it’s installed. Checkmark Android API 28(the top one) if it’s not already (And maybe the Android 8.1(Oreo) as well). And click OK to install.

-You need to fill in the Adaptive Section Background in the icons menu in PlayerSettings in Unity (Just the Background worked for me).

-Build.