Android build error. Failed to re-package resources.

I’m trying to build android app but the process fails with error:

CommandInvokationFailure: Failed to re-package resources.
E:\Google\Android\android-sdk\build-tools\25.0.1\aapt.exe package --auto-add-overlay -v -f -m -J "gen" -M "AndroidManifest.xml" -S "res" -I "E:/Google/Android/android-sdk\platforms\android-25\android.jar" -F bin/resources.ap_ --extra-packages com.familiosystems.RedLotusKingdomRPG.resources -S "C:\projects\rlk\Temp\StagingArea\android-libraries\unity-android-resources\res"

stderr[
C:\projects\rlk\Temp\StagingArea\android-libraries\unity-android-resources\res\values\strings.xml:3: error: A 'name' attribute is required for <string>

C:\projects\rlk\Temp\StagingArea\android-libraries\unity-android-resources\res\values-ru\strings.xml:3: error: A 'name' attribute is required for <string>

]

If I create a new project and try to build it — it builds without any problem.
But I can’t figure out what’s wrong with this one. I’ve built it before but now I can’t.

Unity 5.5.1p2

Ok, I’ve managed to resolve that.
Some of plugins was adding Plugins/Android/res/values/strings.xml with wrong content. It was using <string fxName="app_fxName"> instead of <string name="app_name">. It worked before but doesn’t work now with sdk 25

You probably need to delete temp folder inside the Unity Project folder and build again.

check your plugin/android folder you may have some duplicate files with different version like : play-services-ads-lite-9.2.1 , play-services-ads-lite-10.2.1. delete one of them , it worked fine.