Android : Building Error on unity3.5

Hi , i installed unity3.5 and have problem in building project on Android device ! i plug my device with usb cable to laptop and i installed android sdk but unity show this error :

Error building Player: UnityException: No platforms found
Android SDK does not include any platforms! Did you run Android SDK setup to install the platform(s)?
Minimum platform required for build is Android 4.0 (API level 14)

it`s ask me Android SDK root folder and i select it but its show no platform found !
please help me
tanks

you need to update the android sdk, execute the sdk with administrator right if windows7,you need to update the android sdk, execute with administrator right if windows 7

Problem solved ( at last)

I had initially installed Java 6 (32 bit) but must have somehow installed 64 bit of version 7 later on on ?update.

Although Android SDK recognises V7 64 as acceptable when installing the SDK I don’t think Unity 3.5 does!

Java 32 bit now installed and seems OK - phew!!!

Hope this helps someone else!!!

hi , i installed api level 14 and this error solved but my apk still run just on emulator android 4 and not for lower api level like 3 or 2 . is there any way for create a apk for android version lower 4 ?sorry for my bad english

i have the same problem with sdk . when i try to run my app in lower platform of 4 in avd manager my app just run in virtual device that has (armeabi v7)in front of its name . can any one help me? i set minimum api to api 7 and device filtering to armv7 only .sorry for my bad english

I solved this by installing the Android SDK manually.

The main Android SDK page links to the bundle download (ADT bundle). The bundle install does not seem to work with Unity (I believe it’s because the folder names for the platforms are different in the bundle install, but I haven’t verified this).

I got the SDK instead from the link under “Use an existing IDE”, and manually installed the SDK. Now everything works like a charm.

If you get a “No Platforms Found” error:

  1. Uninstall the current Android SDK and make sure that you don’t have any more copies of it.

  2. Update Java with an stable version. Bear in mind the latest version shouldn’t have conflicts, but users have experienced problems in the past.

  3. Download a fresh copy of the latest ADT Bundle and install it following instructions, this should configure the development tools correctly:
    Download Android Studio & App Tools - Android Developers

  4. Configure Unity with the installed Android SDK.

If you have problems with the editor read this guide: