Android Deployment Hang on "Pushing new content to device"

Hi All, I hope you can help me with this.

Originally I was working on Unity 3.3 on a Windows Vista 32bit machine. I had everything set up and working fine, including the android sdk, jdk, etc. When I hit the build and run command, everything went smoothly and my tablet started playing the game.

However, the laptop died, I bought a new one, and now Unity is seemingly hanging when it’s pushing new content to device. My new laptop is a Windows 7 64bit machine, running Unity 3.5. I upgraded the project and built and ran into to the device with no problems. A second build causes Unity to hang on “pushing new content”.

It can clearly build the apk file, as the build command works fine. I’ve got both 32bit and 64bit versions of the jdk installed, and the android sdk has 4.0.3 installed, as well as 3.2 & 2.3.3 for my two android devices. Both suffer from this problem.

I have tried the following to solve this:

  • Reinstalled the android sdk
  • Reinstalled both jdks
  • Reinstalled the device drivers for the android devices
  • Uninstalled the 64 bit verion of the jdk and then reinstalled the android sdk

Of note is that Unity doesn’t become entirely unresponsive, it just has the dialog stating that it’s pushing new content up. The progress bar doesn’t move forward, though it does do that flash across as if it’s still working. It stays like this for seemingly ever. Hell, it’s running right now and that dialog has been up for at least half an hour at this stage.

I find the only way to break out of this is to either end the Unity process or both of the adb.exe processes running.

If anyone has any idea about what to do, please let me know. I’m literally at my wits end with this.

Finally found the answer to this problem; so for anyone developing on Android, please do not plug your device into a USB 3 port. By accident I plugged in my phone to the USB 2 port on the side of my laptop and found everything worked fine, everytime.

So, if you’re getting the above problem and have no idea what’s causing it; check your USB port. 2.0 is fine, 3.0 not so much.

Hi, I had this problem too and it turns out that my nexus 7 was connected as a media device and therefor adb could not see it. Unintuitively, the solution was to select the second option, connect as camera (ptp). To make the switch, swipe your finger from the top of the screen down to reveal the panel and find the option "camera (ptp).

Here is where I got this answer:

I had the same problem, but the culprit was different - the USB cable I was using was damaged. Actually, I’ve had two USB cables break on me - the first was packaged with my Samsung Galaxy S, and the second one with the Galaxy S3. Even though the cable recognizes that it is plugged in and is capable of receiving power, data transfer may not be possible. Try seeing if you can use the USB cable to transfer files to your phone. If it hangs up in the middle of that, you might need a new cable.

I don’t know what it is about these cables that makes them susceptible to damage; maybe Samsung makes crappy cables, or perhaps it’s something about USB in general, but I’ve never seen this happen with iPod cables.

Another workaround to this problem is to not Build & run, but instead build and then sideload the apk using another application. In my case, I have an LG phone, so I use the LG PC Suite to install the apk on my phone, which works just fine. And its fast too.