Android Manifest xml missing - Build failed. Need Help!

Hi, when I try to build my game to Android it failes with the error: …“\Temp\StagingArea\android-libraries\GooglePlayGamesManifest.plugin’ is missing AndroidManifest.xml file.
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr) (at C:/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:179)”

That means the AndroidManifest.xml file is missing but I cant find it and dont know what to do if I would. Im stuck and Need your help… When I created a new game and build it on Android it worked so it has something to do with my specific game. Maybe I deleted the manifest
accidentally? What should I do? Sorry for my bad english.

Late reply but I found out a way to fix this. I am using Admob, which was causing the problem. In my case, the build was looking for the path Plugins/Android/GoogleMobileAdsPlugin.androidlib/AndroidManifest.xml however the path that was there was called Plugins/Android/GoogleMobileAdsPlugin/AndroidManifest.xml. changing the folder name seems to have fixed the issue for me.

I discovered it by looking in ManifestProcessor.cs, which had the lines

string manifestPath = Path.Combine(

        XDocument manifest = null;
            manifest = XDocument.Load(manifestPath);
        #pragma warning disable 0168
        catch (IOException e)
        #pragma warning restore 0168
            StopBuildWithMessage("AndroidManifest.xml is missing. Try re-importing the plugin.");

adding + e.ToString() allows you to see the full error and further debug it.

I hope this helps anyone else who was having this problem :slight_smile:

@TrueKayobi Were you able to solve this issue?
I’ve got the same issue. I was using Google Play services and everything worked fine. Now that I want to publish the game for IOS as well, I thought of using Cloudonce instead. I deleted the google play folder as Cloudonce already comes with it. I think I might have deleted something else too before importing CloudOnce although AndroidManifest is still there in the main folder (Asset/Plugin/Android). I hope I can get some clue as to what I might have done wrong.

Same Issue, no answer

Have same issue after updating cloudOnce. Basically each time I update it I get these kind of troubles. And it’s impossible to understand what’s going on. Unfortunately the guy who releases the library updates is not writing any migration notes. :confused: