Android module not shown in editor.

I have installed Unity Hub on Ubuntu 19.10 (64-bit).
Later i installed unity 2019.2.21f1 and 2018.4.17f1 using the unity hub.
I installed android modules for both the unity versions and also selected Android sdk and jdk while installing;
In the hub, it shows the modules installed. But when I open any of the editors and go to Build settings and select Android,it shows that no Android module is installed.
What should I do to solve the problem?

For me I only needed to restart Unity.

I have exactly this same problem if anyone can help please do I will really appreciate it.

Posting this here because it’s high in Google search results. This forum post explains why this happens and how to fix it. The problem is that UnityHub will download all the required files to the wrong directory, in my case it was putting them where the UnityHub.appimage had been.
It should instead put them into Unity/2019.xx.xx/Editor/Data/PlaybackEngines/AndroidPlayer. If you need to know where that folder is, click on Installs in Unity Hub, click on the hamburger menu for the version you want and click Show in File Browser.


I moved all the files to the correct folder, restarted Unity and Android was available in the build settings.
Just make sure you put them in the correct editor version folder. I messed that one up.
Here are all the files you need to move

  • Apk
  • Data
  • Source
  • Tools
  • Variations
  • Whitelists
  • ivy.xml
  • modules.asset
  • UnityEditor.Android.Extensions.dll

I had the same problem, all I did is uninstall the editor and reinstall it from the Unity Archive using “Unity Installer”
Don’t forget to check Android modules when installing. I hope this helps you!

This worked for me … turn on cloud diagnostics and enter your android license key in the in-app purchase