Android SDK is missing required platform api

Minimum platform required is Android 5.0 (API level 21)

I’ve already got API 21 installed.

do i need anything more on this list?

and btw it was working good before upgrading to unity 5.

Hi dear

I find the solution :

Go to your android SDK Manager root folder (e.g : “C:\ProgramFiles\Android”)
At root find “Platforms” folder and inside of it rename your folder if you have “Android_5.0.1” or any thing like that to “android_21” or this style {“Android_”+“Api Level Number e.g:(22 or …)” } if your api is 22 you can rename folder to “Android_22”

the 2nd way :
Go to your unity3d edit>> preferences>> External tools >> Android SDK location not setted properly.

the 3th way :
Reinstall your SDK manager in another place

the 4th way :
Download the latest versions of SDK manager and tools

the 5th way :
Use Android Studio as Android SDK manager

If this answer is solve your problem like it :smiley:

Alright, I had a similar issue, and I solved it. I posted this answer in: as well.

What is happening with that warning notification, is Unity is complaining that it can’t point to the correct Android SDK Tools that your project desires. The one that comes with Unity sometimes doesn’t have all the latest Android API versions, and SDK Tools. So if you set your project to be Max API 29, or 30 (max at the time of writing this), but Unity doesn’t have it as part of its install, it gives you this warning.


  1. Download Android Studio

  2. In Android Studio goto Tools->SDK Manager

  3. Download and update all the latest SDK Platforms and SDK Tools. So in my case I went to the SDK Platforms Tab and downloaded Android 10.0 (Q) platform. Then I went to the SDK Tools tab and installed: Android SDK Build-Tools; Android SDK Command-line Tools; Android SDK Platform-Tools (and anything else you may want).

  4. After installing the desired SDK Platforms, and SDK Tools, take note of your Android SDK Location. In my case it was “C:\Users\milam\AppData\Local\Android\Sdk”. See pic below.

  5. In Unity goto Edit->Preferences and uncheck the box “Android SDK Tools Installed with Unity (recommended)”. Then, goto “Browse” and have it point to the SDK Tools you just installed from Android Studio, at the Android SDK Location. See pic below.

  6. Now goto File->Build Settings

Voila! You should be able to build to your testing devices, and export your build just fine!
I hope this helps you. =)

Still Not Working

I was able to solve this by simply checking the Update SDK to version chosen in the target slot of android settings.

Hi, I fixed this problem by downloading Android SDK tools, downloading the SDK version I wanted, and then dragging that version into the place where Unity stores its SDK versions (if you’ve downloaded any at all). I changed my default location for Android but if you find your folder then the versions are under platforms, and you can drag your desired version to “C:\Program Files\Unity\Hub\Editor\2020.1.1f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\platforms” but that path will change depending on the version of Unity you have as well as which drive Unity is stored on. Make sure that in the Unity editor under “preferences>external tools” you have “Android SDK tools installed with Unity” turned on. Anyways good luck, I spent hours figuring this out.