Android signed APK Installation failed

I have been been working on an App the last month.
Now finaly after days of testing and all bugs fixed i made a final build, signed with a key. Im also using a licenced version of ADK & Unity Android.
When i try to install it my Phone says : Installation failed, ending proces.
Nothing more and nothing less.
I’ve then tried to build it without the Key, then it does work.
I was using the JDK Java 1.7 but i found out on the forums it was no good, so i switched to JDK 1.6

Now still after ours of reinstalling all kinds of things i still don’t get things workin.
I’ve tried :

  • older JDK
  • Different Unity ( now working with 3.4.2 )
  • Different Android SDK
  • Different build Levels ( Eclair, Gingerbread )
  • New Key-Store creation.

But still i havent found out What i am doing wrong.
Anyone has any clue what i can do?

Kind Regards, Kevin.

Hey kevin Im having the same problem with unity3.5 did u solve the problem?

Dear Midunity,

I solved the problem in the end by completely reinstalling windows.
But that was because after more problems started occuring, now i have the newest JDK installed and it works perfectly…