android texture problem, big pixels?

on android the texture on the terrain is big pixels almost 1x1, is there any way to solve this?!

alt text

Check the Quality Settings for the Android platform (texture resolution set to “Full Res”, instead of “Half Res” or “Quarter Res”.

Experiment with the compression settings of your texture in the import settings (try “Truecolor”, to see whether compression is an issue for you. This will use maximal quality (and maximal memory…) for your texture. Also make sure the filter mode is not set to “Point”. Also, in the import settings there is a headline “Default”, and to the right of that there is an Android icon. Click on it, and make sure there is no “Override” activated - or if it is, do your changes here, instead of the “Default” section, since then these settings will only apply to the Android platform.