Android - Your device does not match the hardware requirements of this application

Whenever i open a specific app made with Unity 5.5.2f1 on my phone, the error message “Your device does not match the hardware requirements of this application” pops up and prevents me from testing my app. I have tested the app on a Galaxy s6, s7 and s8, with the same result. Before, i could delete the Library folder to make it work for a while, but now it no longer helps. Upgrading to unity 2017 gives a bunch of compile errors, so i’d rather not do that. Any help appreciated.

In my case the Graphics API in Build Settings was set to Vulkan and the Rendering Path was Linear. I Rendering Path to Gamma and Checked Auto Graphics API (hiding Graphics API selection box altogether). It worked.

Thank you so much taxvi, it work for me.

For someone else : Project setting → Player → check Auto Graphics API. Im not sure if you have to change Color Space to gamma or not.

some error

@Bunny83 @UnityMaru @UnityCoach @danw_unity @ryan_unity @Unity_gamer

hi , i am facing same problem , my unity game works fine on some android device but on some device it shows "your device does not match the hardware requirements of this application " (SHOWS A PINK SCREEN ON WHOLE DEVICE , AND GAME RUNS IN BACKGROUND). I am using unity 2019.2.4f1 . And there are some things that i have changed in playerSetting->otherSettings->from monodevelop to IL2CPP and ARMv & Arm64 are checked while x86 is unchecked other than this i have not changed anything.

please help me anyone my game not running on some devices , please help me

Unity - Manual: Graphics API support watch this… @RaviVohra

This is still relevant with Unity 2021. Needed a bunch of different screenshots, and though my game worked fine on my personal phone, it was all pink shader-death in the emulator, the auto API button worked like the charm.

if someone else (check Auto Graphics API) doesn’t work for him or her, there is a other way:

  1. uncheck Auto Graphics API
  2. delete vulkan
  3. add OpenGLES2

alt text

second way if you are using emulator like NoxPlayer :

  1. go to performance settings

  2. change graphic rendering mode from (OpenGL +) to (DirectX )

  3. or if your graphic card support OpenGL 3+ (for intel CPU’s: gen3 and above support 3+) you have to update you graphic card driver. (intel ghrapic cards :to find supported OpenGL (right click on desktop → graphic propreties → option and support → information Center (OpenGL * version))

alt text