Animate-kinematic-interpolate not working together

Imagine creating a conveyer-belt, a baseball bat, or a catapult. You want to play an animation that can push around rigid bodies. This is easily accomplished by setting “Animate Physics” on the Animation component, and turning on “Is Kinematic” on the rigid body attached to the animated object. So far so good. But what doesn’t work is setting rigid body interpolation to anything other than “None” (in particular, setting it to “Interpolate” doesn’t work). The effect is that the rigidbody moves in a jittery fashion, whereas any other rigid bodies that it interacts with all move smoothly.

The simple solution is to just crank up the fixed time-step, but this means all physics must run at the faster speed, and that can affect performance (esp. on mobile devices).

I just upgraded to 3.4 and the bug is still there.

Download this simple example project to see what I’m talking about. I have Interpolate set to None, but try setting it to “Interpolate” or “Extrapolate” for amusing (but sad) results. Anyone have a suggestion for me?

i just got this issue. I am using unity3d 5.62.f1. is it fixed in newer versions of unity3d?