Animate unchecking "Apply Root Motion"

I have an imported animated body named “magnum” and I did it child of my FPS Main camera. When I play the scene, “magnum” goes to the position (0,0,0). I found some similar questions whose answer was about uncheck “Apply Root Motion”. If I do that, it stays where I want but without any kind of animation (meanwhile I see how the Animator Controller is playing it).

Any idea about how fix it?

Thanks.

I fixed it. I did not set any “Root node”.