AnimatedPropertyUtility.cs' is a binary file instead of a text file When Im creating new project

m creating new project in Unity. Unity says that the project has compile errors and asked me to launch it in safe mode. After I got this error.

error CS2015: 'D:/path/to/project/Editor/Utilities/AnimatedPropertyUtility.cs' is a binary file instead of a text file

I’ve tried to reinstall my unity version and tried to open AnimatedPropertyUtility.cs. VSCode says that it’s binary file and can’t be displayed in editor.

When I installed it first time like 5 days ago it worked without problem. But today when I tried to create new project. It displayed this error

I fixed it. Im just deleted PackageCache wich and reinstalled Unity Timeline package

Hey @zahgamer34!

I am having the same Issue but every time I reinstall the packages or even create a new project even in a whole different version of unity the error still appears, for a lot of packages which I know I need.

Removing the packages is a fix in the really short run, as they will 100% be needed for me to continue work on my project, and I was curious, since you had this issue before, have you found a definitive fix for it?