Animation bug?

Hello their, I have an animation for the player of my game. So the problem is that the animation I made it says is “read only”, yes I know this has been asked a bunch of times but usually when the question is asked they imported the animation, I made my animation within Unity. I can add keyframes but not delete any. I also can’t make new animations for my player, I tried deleting the animation in the assets folder but it doesn’t delete. I am getting frustrated and I am making good progress on this game and don’t want to make a new game just because of a crappy, stupid animation that doesn’t work (sorry, just mad), is this a simple problem that can easily be solved? Is it a strange glitch? Should I report it to Unity? Is this a noob question? If you could help me fix this or help know what I did or what is going wrong or know any good sources that could be helpful that would be great!

Thanks :slight_smile:

_1

Is it the First Person Controller you’re using?
Because it could be that you cant attach animations to that…
Have you tried attaching the animation to a cube or something, to see it it works on something simple?

Hope this is helping!
Mathijs.