Animation clip doesn't play

I have a GameObject with two animation layers, the first one controls the lower part of the body, while the second one controls the upper part (aiming, hold aiming, shooting). This is the second layer:

121898-screen-shot-2018-07-31-at-31641-pm.png

The triggers and variables are set correctly, which means that all transitions are ok. The problem comes with the Hold_Point state, which is supposed to act as an “Idle” animation for when the character is pointing his gun. The Hold_Point state animation is not working, even though it has a clip, so when the hold_point state is active, the character just goes back to the start position.

Here you can see such clip.

So to summarize, the clip in the Hold_Point is not playing, even though the transitions between the point, unpoint, and hold are being made correctly. In case you ask what is the animation supposed to do: Nothing. The animation should only hold the position of the character in the position you are watching in the second picture. Those keyframes literally have the same position.

What have I tried:

  • Unchecking Loop Time
  • Apply some little motion to the animation (rotate the pistol just a little bit)
  • Remove the clip of the Hold_Point state (It moves the character back to the start position)

Thank you in advance. Any help is greatly appreciated.

So I have worked out the answer myself, just change the blending mode from additive to override on the second layer.