Animation not getting faster

Hello, I have an animation that I want to be ran faster. However, when I diminish the distance between keyframes in the Animation dopesheet, the animation doesn’t run faster. But when I increase the distance of the keyframes, it gets slower. What can I do to fix this? I’ve even put the keyframes in the same place and it doesn’t change. Thanks in advance!

First, double check it’s really playing the animation you think it’s playing. Then, look at your blend tree. A transition might be creating the appearance of a slow animation. Try setting your transition duration to 0. As you expect, reducing the distance between keys will speed up an animation. There’s likely something ELSE going on here!

You can try this:

142998-capture.jpg

On that samples just decrease that and I think it should “speed up” the animation, but if you are in fact dragging your key frames closer to 0:00, it should shorten (speed up) the animation.


One last thing, make sure you are hitting that record button when you adjust key frames, maybe it’s not saving when you move them around.