Animation shakes in Unity (fbx import from Maya)

I have had this issue when importing from Maya for over a month now and I have spent countless hours trying to find a solution with no luck.

I have a basic ik rig in Maya (no bells or whistles just bones, control objects and skinning) that I am exporting into Unity via fbx. Being that it is an ik set up I have baked the animation and deleted my ik's and effectors. I use the "@" naming convention and bring it into Unity. Everything plays as it should, however, throughout the animation the character will shake as if it has a turbulence modifier on it or something. Thats really the best way I can describe it.

I have tried every way of exporting I can think of. I have tried different versions of the fbx export, importing the .mb file directly, baking in Maya, baking with the fbx export. I have even stripped my rig down to just the core essentials.

Does anyone have any idea why I still get shaking in my animation?

This question is old but it’s the first to appear when you type “unity animation shaking” in google. So I will be telling how I fixed that problem for ppl that type that in google in the future.

This solution is for Blender, but Maya probably has a similar option:
In the fbx export settings there’s a tab called animation (below “fbx version”). Click there and then change “Simplify” value to “0” (default is 1)

In Unity you probably need to turn off animation compression for that animation too.

Maybe you have your character faraway from the center of the world? That could cause shaking due to floating point limited precession

We had this problem today and seemed to solve it by using fbx version 2010 instead of 2011 which seems to have bugs. Also make sure that your .fbx settings are not baking the animation again (this isn't necessary as youve already done it in maya) and also check that Unity isn't reducing your key frames in the import settings.

I had the same problem but i worked in Blender. (In Blender) Go to edit mode, select a bone and make sure “Roll” is set to 0. Repeat for every bone.

Hi Earlage,

i am kiran .you got answer? please tell me solution?

Wow, this brings me back. I actually remember fixing it by checking the export back in 3ds max. Meaning, I’d export it, import it, and make sure everything was okay. Every time unity messed up, it was because of a faulty export.

Iv’e been dealing with this problem for months now but I somehow managed to fix it by selecting a “root node” object in the fbx’s import settings under “rig”. I know this response is super late but i figured if it worked for me it may help someone else, eventually.

Here is my solution. I had this problem exporting a quick rig character from Maya to unity. Even if I just moved the hip controller up and that is it, the legs would shake pretty noticeably. In unity click on your exported motion rig. in the import settings click on the animation tab. and fiddle with the animation compression settings. For me turning them off completely did it for me. No more shaking. Good luck.

Even today people are experiencing this problem with all 3D applications. If you’ll reimport your *.fbx file back to 3D application and see that everything is fine than the problem is on Unity side. It seems one of the reasons of this shaking issue is that Unity playing animation not only on 30fps but much faster. So it trying to interpolate existing keys and kind of ‘fill holes’ between frames.
What helped me is scaling animation two times longer and then export it as usual and playing in engine two times faster. This provides more important information to Unity. Because of short animations I have no drastic changes in .fbx file size.

Had the same issue with Blender, don’t know if I did something or it fixed its self but here is what I did. I did what @Laiken suggested and set the “Simplify” value to 0, that didn’t work. So then I set it back to 1 and tried again. Exported it to Unity and the jitteriness was still there, but now it was REALY small and barely noticeable, this was good enough for me.

Don’t know if this would help anyone but cheers.

I had the same problem while using Maya, but resolved it in Unity animation import settings by turning Anim Compression and Resample Curves to off.

i have found the solution
try to export it with dae_fbx instead of fbx it and after importing in unity turn off keyframe reduction it will work 100% and thanks me later.