Animation window not showing list of animations, even if i click on the object

Yesterday I created some animations for the Main Camera of the First Person Controller, and everything was working fine, I was able to see the animation (Camera_Idle, Camera_Run… etc) list in the Animation Window. Today, when I tried to edit an animation of the Camera, even if I clicked on it, the Animation Window wasn’t showing any animation to edit at all, only [Create New Clip].

I already had this problem, and I solved it by re-creating the animations, but really, I got bored of re-creating the animations any time I reopen Unity, and I’m really frustrated now, what’s the bug this time? Can I open an animation file manually without clicking on the GameObject it belongs to? Why did the developers of Unity make it so difficult?

I’m trying to edit an animation I made with the Animation Window in Unity, so I already point that I can’t click on the FBX importer and go in “Rig” and do something there, because there is no imported object at all, only Animations entirely made in Unity.

TL;DR: It looks like the Animation Window won’t show your animations if you have an Animator component attached to the selected game object.

For me, I removed the animator component, changed my game object selection away and back, and then my list of animations appeared in the Animation window drop down again. I don’t know why, but I saw this answer in another post, but this post was more SEO friendly.

That technique didn’t work for me. It seems that some animations lose their link with the animation Window. What I had to do was to copy the animations in another folder. Delete the originals, and create them again. Then, as they are now linked again by name, I bring the copies back and replace them in the original folder. I was able to recover what I did like this.

After removing the Animation component from the gameobject, if the animation still does not show up in the Animation window after clicking a certain gameobject in the scene, try finding the animation file in the project window, turn off legacy mode, and then and drag/drop it onto the gameobject in the scene. This is how I fixed the issue of the animation no longer showing up in the animation window for the given gameobject. Make sure to re-enable turn legacy mode when adding the Animation component.

This just happened to me. I solved it by duplicating the animation clips and naming them something unique “XX_idle-1”, “XX_walk-1” etc. Even though the animations were created as separate maya files, and exported to .fbx with unique names when they were brought into unity the clips names all read “Take 001” respectively. I think Unity gets confused when you drop them into the mechanim window, even if you re-name the state to something unique the Motion field still references the clip from the project.

Hi I had a similar problem with missing animations in the animation Window dropdown. In my setup I am using a Animator Override Controller to swap animations after loading scenes. Adding the missing animation to the Animator Override Controller as one of the override entries before clicking the dropdown in the Animation Window enabled editing of the previously missing animation.

For Me, Close and Restarting Unity Editor Works Perfectly…

You are a wizard. Thanks a lot. That solved lot of my problems

Can’t find your Animations in the dropdown?

So this isn’t a bug, per se… It’s more like a “stupid feature that kind of makes sense” which seems to be an extremely annoying and persistent theme in Mecanim.

If you click something with an Animator on it to do some animation then the Animator is required to have a reference to the Animation you want to start modifying. If you want to see the new animations in the dropdown then you have to go to the Animator and drag them all into it so it has a reference to them. Otherwise, it will only show Animations it has a reference to in the Animator in the Animation dropdown. You don’t have to link anything to them, just drag them in and hide them somewhere so they don’t annoy you too much.

I assume this is to reduce clutter because any decent 2d project will have hundreds of animations. Animations that are not used in any Animator will never be shown in the Animation dropdown.

1/Attach animation controller to a gameobject.
2/select the gameobject to edit the animation of
3/go to window/animation… the animation containing the selected object will appear.